您现在位置:首页 > 职能部门 > 信息处 > 网络中心 > 正文

下文

华三交换机常用配置命令
2019-11-12 14:52:23   来源:本站原创   录入:刘有根  评论:0 点击:

内容提要:   华三交换机常用配置命令全称与简写display=dis,interface=int,brief=b常用设备信息查看<h3c>display device 显示设备硬件信息display clock 查看时间display cpu 查看CPU使用率display memory 查看内存使

华三交换机常用配置命令

全称与简写display=dis,interface=int,brief=b
常用设备信息查看
  1. <h3c>display device 显示设备硬件信息
  2. display clock 查看时间
  3. display cpu 查看CPU使用率
  4. display memory 查看内存使用情况
  5. display fan 查看风扇
  6. display power 查看电源
  7. display current-configuration  显示当前生效的配置
  8. display current-configuration interface只显示当前端口的配置
  9. display memory 查看内存大小和占用率
  10. display interface 接口流量、链路状态
  11. display ip routing-table 路由信息
  12. display ip interface 显示ip端口统计数据
  13. display ip interface brief 显示ip端口基本数据
  14. display logbuffer 日志信息
  15. display port trunk 查看参与trunk的端口
  16. display link-aggregation summary 查看链路聚合组的情况
  17. display arp #查看全局ip
<>18.19.20.system-view 进入系统视图模式
  • sysname 为设备命名
  • interface Ethernet 1/0/1 进入以太网端口视图
  • undo shutdown 打开以太网端口
  • shutdown 关闭以太网端口
  • reboot  重启交换机
  • quit 退出当前视图模式回到低一级视图
  • return回到用户视图,交换机视图分为三个级别,由低到高分别为:用户视图、系统视图、VLAN视图、以太网端口视图等,如果当前视图是用户视图,则退出系统
  • H3C VLan设置
    1.创建vlan:
    <H3C>                   //用户直行模式提示符,用户视图
    <H3C>system-view        //进入配置视图
    [H3C] vlan 10  //创建vlan 10,并进入vlan10配置视图,如存在就直接进入
    [H3C-vlan10] quit    //回到配置视图
    2.将端口加入到vlan中:
    [H3C] interface GigabitEthernet1/0/0 //进入1号插槽上的第一个千兆网口。
    [H3C- GigabitEthernet1/0/0] port link-type access   //定义端口传输模式
    [H3C- GigabitEthernet2/0/1] port default vlan 10    //将这个端口加入到vlan10中
    [H3C- GigabitEthernet2/0/1] quit
    3.将多个端口加入到VLAN中
    <H3C>system-view
    [H3C]vlan 10
    [H3C-vlan10]port GigabitEthernet 1/0/1 to GigabitEthernet 1/0/29 
    [H3C-vlan10]quit
    交换机配置IP地址
    [H3C] interface Vlan-interface100  // 进入vlan100接口视图与vlan 100进入的地方不同
    [H3C-Vlan-interface100] ip address 19.67.20.9 255.255.255.0 // 定义vlan100管理IP三层                             交换网关路由
    [H3C-Vlan-interface100] quit
    配置默认网关:
    [H3C]ip route-static 0.0.0.0  0.0.0.0  119.167.200.89 //配置默认网关。
    <H3C>save                           //保存配置信息
    配置trunk命令
    <Quidway>system-view  //----进入系统配置模式
    [Quidway]
    [Quidway]VLAN 100 //---创建VLAN---ID为:100
    [Quidway-vlan100] port Ethernet 1/0/1 to Ethernet 1/0/10 //----添加到VLAN 100
    [Quidway] interface Vlan-interface 100 //—进入VLAN 100
    [Quidway-Vlan-interface100]ip address 192.168.100.254 255.255.255.0 //---配置管理IP
    [Quidway-Vlan-interface100]quit
    [Quidway]ip route-static 0.0.0.0  0.0.0.0   192.168.100.33 //—配置静态路由(网关)
    上联端口为千兆端口GigabitEthernet1/1/1在配置模式下配置命令如下:
    [Quidway] interface GigabitEthernet 1/1/1 //---进入上联端口
    [Quidway-GigabitEthernet1/1/1] port link-type trunk //--TRUNK是端口汇聚的意思
    [Quidway-GigabitEthernet1/1/1] port trunk permit(允许)vlan all //----允许通过的VLAN
    如果上联的路由器端口是自适应那么交换机上联口也是自适应,如果配置了1000M全双工那么交换机的上联端口也要配成1000M全双工。如下命令:
    [Quidway-GigabitEthernet1/1/1] duplex full //—配置端口为“全双工状态”
    [Quidway-GigabitEthernet1/1/1] speed 1000  //---配置端口为“1000M”
    H3C交换机端口汇聚
    1.建立汇聚组1
    [SwitchA]interface bridge-aggregation 1
    2.进入端口G1/0/1
    [SwitchA]interface gigabitethernet1/0/1
    3.参与端口汇聚的端口设置成全双工模式
    [SwitchA-GigabitEthernet1/0/1]duplex full
    4.参与端口汇聚的端口工作速率设置一致
    [SwitchA-GigabitEthernet1/0/1]speed 1000
    5.将端口加入汇聚组
    [SwitchA-GigabitEthernet1/0/1]port link-aggregation group 1
    6.端口G1/0/2与端口G1/0/1的配置一致
    7.负荷分担基于源MAC和目的MAC
    [SwitchA]link-aggregation load-sharing mode source-mac  静态路由
    ip route-static 202.0.1.0 255.255.255.0 192.0.0.2 preference 60目标地址 掩码 下一条地址 优先级
    ip route-static命令用来配置静态路由。undo ip route-static命令用来删除静态路由。当目的IP地址和掩码均为0.0.0.0时,就是配置的缺省路由。
    配置dhcp
    1.创建(进入)VLAN2 
    [Switch]vlan 2 
    2.将E1/0/1端口加入VLAN2 
    [Switch-vlan2]port Ethernet1/0/2 
    3.进入VLAN接口2 
    [Switch-vlan2]int vlan 2 
    4.为VLAN2配置IP地址
    [Switch-Vlan-interface2]ip address 192.168.0.1 255.255.255.0
    5.全局使能DHCP功能
     [Switch]dhcp enable 
    6.创建DHCP地址池并进入DHCP地址池视图
     [Switch]dhcp server ip-pool h3c 
    7.配置动态分配的IP地址范围
    [Switch-dhcp-pool-h3c]network 192.168.0.1 mask 255.255.255.0 
    8.配置网关地址
     [Switch-dhcp-pool-h3c] gateway-list 192.168.0.1 
    9.禁止将PC机的网关地址分配给用户
     [Switch]dhcp server forbidden-ip 192.168.0.1 
    10.指定vlan2虚接口工作在全局地址池模式
     [Switch]dhcp select global interface vlan-interface 2
    配置关键点:
    1.需保证虚接口地址在地址池中,这样VLAN下接的PC机方能自动获得192.168.0.0/24网段的IP地址;
    2.当虚接口工作在全局地址池模式时使用以下命令:[Switch]dhcp select global all
     
    中继DHCP配置
    1.全局使能DHCP功能(缺省情况下,DHCP功能处于使能状态)
     [SwitchA]dhcp enable 
    2.创建(进入)VLAN100 
    [SwitchA]vlan 100 
    3.将G1/1加入到VLAN100 
    [SwitchA-vlan100]port GigabitEthernet 1/1 
    4.创建(进入)VLAN接口100  
    [SwitchA]interface Vlan-interface 100 
    5.为VLAN接口100配置IP地址
    [SwitchA-Vlan-interface100]ip address 192.168.0.1 255.255.255.0 
    6.创建(进入)VLAN10 
    [SwitchA]vlan 10 
    7.将E0/1-E0/10加入到VLAN10 
    [SwitchA-vlan10]port Ethernet 0/1 to Ethernet 0/10 
    8.创建(进入)VLAN接口10 
    [SwitchA]interface Vlan-interface 10 
    9.为VLAN接口10配置IP地址
    [SwitchA-Vlan-interface10]ip address 10.10.1.1 255.255.255.0 
    10. 使能VLAN接口10的DHCP中继功能
    [SwitchA-Vlan-interface10]dhcp select relay 
    11. 为VLAN接口10配置DHCP服务器的地址
     [SwitchA-Vlan-interface10]ip relay address 192.168.0.10
    【补充说明】
    也可以在全局配置模式下,使能某个或某些VLAN接口上的DHCP中继功能,例如:
    [SwitchA]dhcp select relay interface Vlan-interface 10
     
    配置DHCP SNOOPING
    # 使能 DHCP Snooping 功能。
    system-view
    [SwitchB] dhcp-snooping
    # 配置 GigabitEthernet1/0/1 端口为信任端口。
    [SwitchB] interface gigabitethernet1/0/1
    [SwitchB-GigabitEthernet1/0/1] dhcp-snooping trust
    [SwitchB-GigabitEthernet1/0/1] quit

相关热词搜索:

上一篇:锐捷交换机常用功能配置
下一篇:最后一页

分享到: 收藏